锐捷AC+AP简单实例

最后修改时间:2018年11月28日

文档版本:1.0

本文章使用的设备如下:

安全网关EG:RG-EG-2000K
核心交换机SW:RG-S5750-24GT4XS-L
无线控制器AC:RG-WS6008
无线接入点AP:RG-AP520

拓扑图如下:

网关EG配置如下:

Ruijie>en
Ruijie#config
Enter configuration commands, one per line. End with CNTL/Z.
 
Ruijie(config)#int gi 0/0
Ruijie(config-if-GigabitEthernet 0/0)#ip ad 192.168.1.2 30
Ruijie(config-if-GigabitEthernet 0/0)#int gi 0/6
Ruijie(config-if-GigabitEthernet 0/6)#ip ad 192.168.0.100 24
Ruijie(config-if-GigabitEthernet 0/6)#exit
 
Ruijie(config)#access-list 1 permit 192.168.10.0 0.0.0.255
Ruijie(config)#ip nat pool nat_pool 192.168.0.200 192.168.0.200 netmask 255.255.255.0
Ruijie(config)#ip nat inside source list 1 pool nat_pool
 
Ruijie(config)#router ospf
Ruijie(config-router)#network 192.168.1.0 0.0.0.3 area 0
Ruijie(config-router)#default-information originate always
Ruijie(config-router)#exit
 
Ruijie(config)#ip route 0.0.0.0 0.0.0.0 192.168.0.1

交换机SW配置如下:

Ruijie>en
Ruijie#config
Enter configuration commands, one per line. End with CNTL/Z.
 
Ruijie(config)#vlan 10
Ruijie(config-vlan)#vlan 20
Ruijie(config-vlan)#vlan 30
Ruijie(config-vlan)#exit
 
Ruijie(config)#int vlan 10
Ruijie(config-if-VLAN 10)#ip ad 192.168.10.1 24
Ruijie(config-if-VLAN 10)#int vlan 20
Ruijie(config-if-VLAN 20)#ip ad 192.168.20.1 24
Ruijie(config-if-VLAN 20)#int vlan 30
Ruijie(config-if-VLAN 30)#ip ad 192.168.30.1 24
Ruijie(config-if-VLAN 30)#exit
 
Ruijie(config)# int gi 0/1
Ruijie(config-if-GigabitEthernet 0/1)#no switchport
Ruijie(config-if-GigabitEthernet 0/1)#ip ad 192.168.1.1 30
Ruijie(config-if-GigabitEthernet 0/1)#int gi 0/2
Ruijie(config-if-GigabitEthernet 0/2)#switchport mode trunk
Ruijie(config-if-GigabitEthernet 0/2)#int gi 0/3
Ruijie(config-if-GigabitEthernet 0/3)#switchport access vlan 20
Ruijie(config-if-GigabitEthernet 0/3)#exit
 
Ruijie(config)#router ospf
Ruijie(config-router)#network 192.168.10.0 0.0.0.255 area 0
Ruijie(config-router)#network 192.168.1.0 0.0.0.3 area 0
Ruijie(config-router)#exit
Ruijie(config)#ip route 1.1.1.1 255.255.255.255 192.168.30.2
 
Ruijie(config)#service dhcp
Ruijie(config)#ip dhcp pool ap
Ruijie(dhcp-config)#option 138 ip 1.1.1.1
Ruijie(dhcp-config)#network 192.168.20.0 255.255.255.0
Ruijie(dhcp-config)#default-router 192.168.20.1
Ruijie(dhcp-config)#exit
 
Ruijie(config)#ip dhcp pool user
Ruijie(dhcp-config)#network 192.168.10.0 255.255.255.0
Ruijie(dhcp-config)#default-router 192.168.10.1
Ruijie(dhcp-config)#dns-server 1.2.4.8

无线控制器AC配置如下:

Ruijie>en
Ruijie#config
Enter configuration commands, one per line. End with CNTL/Z.
 
Ruijie(config)#int l0
*Nov 28 10:13:31: %LINK-3-UPDOWN: Interface Loopback 0, changed state to up.
*Nov 28 10:13:31: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback 0, changed state to up.
Ruijie(config-if-Loopback 0)#ip ad 1.1.1.1 32
*Nov 28 10:13:38: %CAPWAP-6-ADDRESS_CHANGE: Get new address [1.1.1.1] with interface [Loopback 0] now.
Ruijie(config-if-Loopback 0)#exit
 
Ruijie(config)#wlan-config 1 Ruijie
Ruijie(config-wlan)exit
 
Ruijie(config-group)#ap-group default
Ruijie(config-group)#interface-mapping 1 10
Ruijie(config-group)#exit
 
Ruijie(config)#vlan 10
Ruijie(config-vlan)#vlan 30
Ruijie(config)#int vlan 10
Ruijie(config-if-VLAN 10)# int vlan 30
Ruijie(config-if-VLAN 30)#ip ad 192.168.30.2 24
Ruijie(config-if-VLAN 30)#exit
 
Ruijie(config)#int gi 0/1
Ruijie(config-if-GigabitEthernet 0/1)#switchport mode trunk
Ruijie(config-if-GigabitEthernet 0/1)#exit
 
Ruijie(config)#ip route 0.0.0.0 0.0.0.0 192.168.30.1
Leave a Reply